Missing Data Laboratory

Discussion of development versions only
Post Reply
rburke2233
Posts: 3
Joined: 20 Jul 2014 02:55
Location: United States

Missing Data Laboratory

Post by rburke2233 » 20 Jul 2014 03:57

Running Gephi 0.9 (0.9-20140621.160828-388 to be exact) using Java 1.8. (Also happens using Java 1.7)

The Data Laboratory window does not show up: no columns, no data, nothing. This happens on Les Miserables and on my own datasets. This does not happen using 0.8.2. Not sure if this is a known bug or some specific configuration / compatibility issue. I have reproduced the problem on multiple (Windows) machines.

I would happily keep using 0.8.2 but my school is migrating to Java 8 for our labs so I do not have any choice. I am using Gephi for a course in the Fall so this is making me very nervous.

Any idea when a stable Java 8 compatible version will be released?

Robin Burke
DePaul University

hbruch
Posts: 11
Joined: 27 Jul 2014 16:57
Location: Germany, Stuttgart

Re: Missing Data Laboratory

Post by hbruch » 04 Aug 2014 21:41

Hi Robin,

in the 0.9-SNAPSHOT the data laboratory is not yet fully migrated to the new graph engine and hence is disabled.
If 0.8.2 still works for you, you could check out the recently patched 0.8.2 branch which now should work with JDK8 on linux and windows at least.

Best regards,
Holger

rburke2233
Posts: 3
Joined: 20 Jul 2014 02:55
Location: United States

Re: Missing Data Laboratory

Post by rburke2233 » 22 Sep 2014 22:21

I have the latest 0.8.2 snapshot running on Windows with Java 1.8. Thanks for the tip.

Any idea what to do with my Mac users? I tried compiling the 0.8.2 snapshot on OS X with Java 1.8 but was not successful.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests