"Export to new workspace" does not work, loads endlessly with no result

Once it's running
Post Reply
broorg
Posts: 8
Joined: 20 Jun 2017 02:15

"Export to new workspace" does not work, loads endlessly with no result

Post by broorg » 15 Jan 2018 02:46

Actual version 0.9.2.

/edit looks like I ran into this unsolved bug - https://github.com/gephi/gephi/issues/1482

Network: 1,29 million nodes + 1,8 million edges

DL: https://www.dropbox.com/s/8iym8b1v0ed07 ... gephi?dl=0

I have a network which I need to apply the "Giant Component" filter on.
Then, when the filter is applied I click "Export to new workspace" to get the result into a new workspace.
But it just loads into infinity at the right bottom corner and the new workspace remains empty, does not matter if I give it 1 minute or 3 hours.

I tested it with a smaller network (~170k nodes, ~200k edges) and it works without a problem, so I guess my network is too big or something like that?

And why does it take ages to just drop & drag a filter? It's not even applied, that takes even longer and that is okay but dragging a filter should not take any time, what happens in that ~10 minutes I drag & drop?
Last edited by broorg on 16 Jan 2018 01:08, edited 1 time in total.

User avatar
eduramiba
Gephi Code Manager
Posts: 975
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: "Export to new workspace" does not work, loads endless with no result

Post by eduramiba » 15 Jan 2018 13:18

Wow, maybe your Gephi is out of memory an struggling? Try to increase its available memory in the gephi.conf file https://github.com/gephi/gephi/wiki/Troubleshooting

broorg
Posts: 8
Joined: 20 Jun 2017 02:15

Re: "Export to new workspace" does not work, loads endless with no result

Post by broorg » 15 Jan 2018 21:58

I have set my gephi config to 12gb (12000mb) RAM (have 16gb) and it uses about ~3-3,5gb when using that filter or export so that should not be the root of the problem.


Post Reply