[SOLVED] Maven error

Please use a mailing-list, see http://gephi.org/developers/
Post Reply
AndyF1
Posts: 4
Joined: 21 Apr 2013 20:41

[SOLVED] Maven error

Post by AndyF1 » 21 Apr 2013 21:01

Hi all,
I try to get started with Gephi, but when I open the Gephi project in NetBeans, it says "badly formed Maven project" - "requires 3.0.4". I installed Maven 3.0.5 (and also tried with 3.0.4) and NetBeans shows it as the used version, but the error persists. Once I remove the "required version" part from the POM, the project setup works, but it builds an empty jar. Same error on Win and Linux. Netbeans Version is 6.8.
I tried many things that google proposed but nothing helped.
any help would be appreciated.

User avatar
mbastian
Gephi Architect
Posts: 728
Joined: 10 Dec 2009 10:11
Location: San Francisco, CA

Re: Maven error

Post by mbastian » 22 Apr 2013 16:13

Hi Andy, I would suggest updating Netbeans because you have the 6.8 version and the latest version is 7.3. They made a lot of progress on the Maven support since the 7.0. If that still doesn't work, please describe the steps you're doing more precisely so we can debug.

AndyF1
Posts: 4
Joined: 21 Apr 2013 20:41

Re: Maven error

Post by AndyF1 » 22 Apr 2013 21:10

ok, after updating to 7.3. everything works, thanks a lot.

Post Reply