Plugin development in Netbeans: breakpoints not working.

Please use a mailing-list, see http://gephi.org/developers/
Post Reply
olavla
Posts: 2
Joined: 20 Aug 2017 08:50

Plugin development in Netbeans: breakpoints not working.

Post by olavla » 20 Aug 2017 09:06

ff.jpeg
ff.jpeg (39.12 KiB) Viewed 158 times
Hi,

I'm developing a Gephi (filter) plugin in Netbeans and although the plugin run fine, running it in debug mode with a breakpoint never breaks (although I'm sure to hit the code).

How can I ensure it breaks so I can step through my code?

These are my steps:

-Install NetBeans & Maven
-Install gephi-plugins-master.zip
-mvn org.gephi:gephi-maven-plugin:generate
-put all the code in place
-mvn clean package
-mvn org.gephi:gephi-maven-plugin:run

Result: code works 100%

Now I open NetBeans > Open Project & add the plugin folder.
-It shows my plugin as module.
-I double click the module and it opens as its own section (see sceenshot; Module BackTracer)
-I can't run the module on it's own - it can't find certain dependencies.
-I can run the Gephi-plugin project: it starts Gephi and my plugin runs fine.

Now I add some breakpoints in the Module BackTracer, specifically in the BackTracerBuilder (on various points, methods & line breakpoints). I also defined a Class entry breakpoint.

None of those breakpoints ever hit. Why?

Btw: in NetBeans the code shows as containing a lot of errors. However, this is code 100% copied from an existing plugin with some names changed. It runs 100% functional and mvn org.gephi:gephi-maven-plugin:validate doesn't give me any errors/warning. Weird right?

Thanks for your inputs!

Image

olavla
Posts: 2
Joined: 20 Aug 2017 08:50

Re: Plugin development in Netbeans: breakpoints not working.

Post by olavla » 20 Aug 2017 10:59

Solution was to start from scratch and build a new plugin. For some reason the plugin was installed but never updated when I executed, and thus it never hit the code.

Post Reply