after install gephy freezes at starting modules

Problems with getting it running
dd1835692
Posts: 6
Joined: 27 Oct 2017 09:26

after install gephy freezes at starting modules

Post by dd1835692 » 27 Oct 2017 09:48

Hi!

This is on a clean installed windows 10 x64 1709 fully updated and java jre 1.8.0_151-b12. Installation completes without problems, but gephy does not start (it is stuck at starting modules).

The log file (messages) consists only of the settings, and according to that it locates java. There are no errors (I attached the messages file, with edited username).

The interesting piece of data is, that on another computer, that had gephy working it stopped working (with same symptoms) after latest windows updates.


I tried reinstalling gephy and java, tried setting the java home in gephy.conf, I deleted the user\appdata\gephy\ folder, nothing helps. What Else can I try?

Thank you
Attachments
messages.log
(14.17 KiB) Downloaded 10 times

User avatar
eduramiba
Gephi Code Manager
Posts: 954
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: after install gephy freezes at starting modules

Post by eduramiba » 27 Oct 2017 10:33

It seems you are running 32 bit java but a 64 bit Windows. Please make sure to install a 64 bit Java 8 instead of 32 bit.

dd1835692
Posts: 6
Joined: 27 Oct 2017 09:26

Re: after install gephy freezes at starting modules

Post by dd1835692 » 27 Oct 2017 12:53

java is 64 bit.

32 bit would be installed under "program files(x86)" folder not "program files"

at the moment I have only 64 bit java installed

User avatar
eduramiba
Gephi Code Manager
Posts: 954
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: after install gephy freezes at starting modules

Post by eduramiba » 27 Oct 2017 13:03

Oh right, also make sure then your graphics card drivers is up to date.

dd1835692
Posts: 6
Joined: 27 Oct 2017 09:26

Re: after install gephy freezes at starting modules

Post by dd1835692 » 27 Oct 2017 13:57

video drivers are the latest. But it has only intel HD 630 video

User avatar
eduramiba
Gephi Code Manager
Posts: 954
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: after install gephy freezes at starting modules

Post by eduramiba » 28 Oct 2017 22:36

That should work fine.
You can also try to use the tar.gz version of gephi https://github.com/gephi/gephi/releases/tag/v0.9.2 instead of a Windows installer.
Just uncompress it in a folder where you won't have permissions problems and run gephi64.exe in the bin folder.

User avatar
eduramiba
Gephi Code Manager
Posts: 954
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: after install gephy freezes at starting modules

Post by eduramiba » 28 Oct 2017 22:37


dd1835692
Posts: 6
Joined: 27 Oct 2017 09:26

Re: after install gephy freezes at starting modules

Post by dd1835692 » 02 Nov 2017 07:14

nope, same result.

I tried with gephy installed and after uninstall...

does it leave something in registry (so I can delete that as well).

I try every time normally and as an administrator... no change.

User avatar
eduramiba
Gephi Code Manager
Posts: 954
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: after install gephy freezes at starting modules

Post by eduramiba » 02 Nov 2017 08:58


dd1835692
Posts: 6
Joined: 27 Oct 2017 09:26

Re: after install gephy freezes at starting modules

Post by dd1835692 » 02 Nov 2017 10:03

Ok.

I think I identified sophos exploit prevention as the culprit (I tried before with disabled AV, but it seems, it did not disable the exploit prevention).

I'll contact sophos and notify it about a false positive.

Thank you for your help.

Post Reply