Gephi not running on Windows 10

Problems with getting it running
Post Reply
aprenning
Posts: 1
Joined: 23 Nov 2016 16:05

Gephi not running on Windows 10

Post by aprenning » 23 Nov 2016 16:15

Hi,
I have tried to install Gephi 0.9.1 on Windows 10 (with Java v 8). I did the installation as an administrator. However, starting the program, I get the message: OpenGL Es Error - Can't find the name of Intel ICD OpenGL driver.
On Windows 7 I didn't have any problem. I would be very happy for your help.
Alex

User avatar
eduramiba
Gephi Code Manager
Posts: 920
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: Gephi not running on Windows 10

Post by eduramiba » 23 Nov 2016 16:21

You can try to update your graphic card drivers.

PepiJimenez
Posts: 4
Joined: 01 Nov 2016 13:44

Re: Gephi not running on Windows 10

Post by PepiJimenez » 30 Nov 2016 00:15

For Windows 10, 64bits, what do you recommend, I mean, Java version and Gephi versión?
I tried 0.8.2 and 0.9. with different Java and it doesn't not work properly.
Is it possible to have different Java version installed? I need a recent one for working and some people recommend gephi with jdk 7 even for Windows 10.

User avatar
eduramiba
Gephi Code Manager
Posts: 920
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: Gephi not running on Windows 10

Post by eduramiba » 30 Nov 2016 09:55

Hi,
You can have multiple java versions installed and just uncomment the jdkhome line in gephi/etc/gephi.conf file to point to the java installation that you need.

Gephi 0.8.2 won't probably work with Java 8+ in windows.
Gephi 0.9.1 should work with all java versions.

PepiJimenez
Posts: 4
Joined: 01 Nov 2016 13:44

Re: Gephi not running on Windows 10

Post by PepiJimenez » 30 Nov 2016 20:02

Thanks Eduramiba,
I did it. It works, for instance installing Gephy 0.9.1, in Windows 10 Pro 64-bit and Java 1.7.0_79.

But there are some things that are extrange:
- It informs that the System is: "Windows 8.1 version 6.3 running in amd64". I cannot understand this, as the computer never had Windows 8.1.
- The screen is also extrange, some titles are very small (for instance, "Layout", but in other areas the size is Ok). I do not know if there is something to be changed in settings as the other software in the computer is perfect.
- It converted a GDF file from a Directed to a Non-Directed network. With other computer with the same Java but 0.8.2 it was correctly imported as a Directed network.

Apart from these failures that I would like to understand and solve, Gephi 0.9.1 could calculate modularity etc, and also graph an almost 1 million nodes network.

Doc HT
Posts: 1
Joined: 02 Feb 2017 15:38

Re: Gephi not running on Windows 10

Post by Doc HT » 02 Feb 2017 15:44

Same Problem here.

The message occurs: OpenGL Es Error - Can't find the name of Intel ICD OpenGL driver.

All drivers on my Lenovo T460 are up-to-date. JAVA is up-to-date.

When I try to start the 64bit-Version of Gephi out of it's folder it says it cannot find JAVA 1.7.

It seems that the configuration-files of Gephi ar not correct.

Can anyone provide a solution to fix this?

reichmaj
Posts: 2
Joined: 26 Feb 2017 22:56

Re: Gephi not running on Windows 10

Post by reichmaj » 26 Feb 2017 22:59

Having the same issue Windows 10, Lenovo T460.

Tried jdkhome="C:/Program Files (x86)/Java/jre1.8.0_121/bin/javaw.exe" but that didn't seem to work

reichmaj
Posts: 2
Joined: 26 Feb 2017 22:56

Re: Gephi not running on Windows 10

Post by reichmaj » 28 Feb 2017 03:47

Form, A class mate sent me this and I was able to install on my Lenovo T460

Gephi is tricky to install. Issues with the OpenGL error is a combination of Java and 32 bit vs 64 bit Gephi and Windows 10.

On 64 bit machine using Windows 10, here's how to fix:

1) Make sure 64bit Java runtime is installed oracle.com and download to get Java JRE 1.8

2) Go to C:\Program Files (x86)\Gephi-0.9.1\bin\. Note Gephi installs itself in 32-bit Program files! There is gephi.exe and gephi64.exe. You need to run gephi64.exe on 64bit Windows 10 machines.

3) Go to start menu, right-click the shortcut and view file location.

4) Right-click the icon then click properties. You'll see a directory path. Make sure it is launching gephi64.exe.

cmp2_gmu
Posts: 1
Joined: 14 Apr 2017 15:29

Re: Gephi not running on Windows 10

Post by cmp2_gmu » 14 Apr 2017 15:37

Just wanted to confirm what reichmaj posted above worked for me (for future reference). I had purchased a new ASUS K501U, running Windows 10 with a 64-bit Intel i7-6500 CPU. It also has an integrated graphics card (Intel HD 520) and a NVIDIA GTX 960M. All searches blamed the video drivers, but this was a rabbit hole (at least for this issue). The issue is that Gephi defaults to the 32-bit program which appears to have a conflict with the 64-bit OS in the newest Windows updates (it still runs fine in default mode on my older laptop, also with Windows 10).

Recommend going to Java.com, manually downloading Java 8.x 64-Bit (offline) to force the 64-bit installation. Then, ensure you point all shortcuts and associations to the gephi64.exe executable. This immediately solved the problem form me.

Thanks again reichmaj.... wish I would have seen your post 3 days ago!

Post Reply