installation problems

Problems with getting it running
patricia.aparecida
Posts: 2
Joined: 14 Sep 2014 11:16

installation problems

Post by patricia.aparecida » 14 Sep 2014 11:30

I installed the 0.8.2-beta version of gephi in windows Vista operating system, with jdk1.8.0_05 and jre8; but when I do a double click on the icon gephi it will not boot. How can I solve the problem?

masoud
Posts: 3
Joined: 16 Sep 2014 19:50

Re: installation problems

Post by masoud » 16 Sep 2014 20:07

Dear patricia.aparecida

You need Java Development Kit (JDK) 1.7 to run Gephi, I had version 1.8 but it did not work, I installed 1.7 and I have Gephi running perfectly on windows 8 (x64) with Java 1.7 (x64).
The good news is that you do not need to uninstall Java 1.8, you can install Java 1.7 at the same time.

Instructions:
1. Head over to http://www.oracle.com/technetwork/java/ ... 80260.html and install Java 1.7
2. Go to your Gephi installation folder (probably C:\Program Files (x86)\Gephi-0.8.2) and locate the folder etc
3. Inside etc folder you will find a file named gephi.config, open this file with notepad.
4. Search for the keyword #jdkhome="/path/to/jdk"
5. Once you find this part of code, remove the # from the beginning since the machine will not execute this code and it will consider it as comment.
6. Replace the text inside double quotations /path/to/jdk with the directory address of your Java folder. In order to find your Java folder, check your windows drive (probably C:), and go to Program Files, and find the folder Java, inside that folder you will find a folder that starts with "jdk1.7". You need to copy the address of this folder and paste it instead of /path/to/jdk in the gephi.config file.
For me it was C:\Program Files\Java\jdk1.7.0_67.
7. Save the config file, if you are not allowed to do so save it on some other place and once done, replace it on the original file.

So to sum up, remove the # from gephi.config, replace the JDK path with your Java1.7 folder, and you're done!

Let me know if you have any questions, and please let me know if I can make these instructions any better in any way since I'd wish for it to be the ultimate solution for everyone, I had to run around in the forum to figure what I have to do.

patricia.aparecida
Posts: 2
Joined: 14 Sep 2014 11:16

Re: installation problems

Post by patricia.aparecida » 20 Sep 2014 01:04

Thank you for the instructions

I did exactly as you said and the gephi worked properly.

prankor
Posts: 1
Joined: 10 Oct 2014 05:56

Re: installation problems

Post by prankor » 10 Oct 2014 06:01

masoud, thank you so much, worked for me as well. Windows 8.1, 64 bit.

tedhowell
Posts: 1
Joined: 21 Oct 2014 15:50
Location: United States

Re: installation problems

Post by tedhowell » 21 Oct 2014 15:54

Thanks for the instructions. I was able to do this despite not having ever seen a .conf file before, so I appreciate the step-by-step clarity.

panklam
Posts: 9
Joined: 04 Oct 2012 21:48

Re: installation problems

Post by panklam » 08 Nov 2014 17:43

This Java site has so many items ... is it the java developer's kit? Can someone tell me the exact name of the Java kit to download?

... and reassure me it will work on Windows 7 64-bit.

thanks!

patti

Joshua20
Posts: 1
Joined: 12 Nov 2014 18:24
Location: United Kingdom

Re: installation problems

Post by Joshua20 » 12 Nov 2014 18:30

I am still having a problem
the config file reads ...

# ${HOME} will be replaced by user home directory according to platform
default_userdir="${HOME}/.${APPNAME}/0.8.2/dev"
default_mac_userdir="${HOME}/Library/Application Support/${APPNAME}/0.8.2/dev"

# options used by the launcher by default, can be overridden by explicit
# command line switches
default_options="--branding gephi -J-Xms64m -J-Xmx512m -J-Xverify:none -J-Dsun.java2d.noddraw=true -J-Dsun.awt.noerasebackground=true -J-Dnetbeans.indexing.noFileRefresh=true -J-Dplugin.manager.check.interval=EVERY_DAY"
# for development purposes you may wish to append: -J-Dnetbeans.logger.console=true -J-ea

# default location of JDK/JRE, can be overridden by using --jdkhome <dir> switch jdkhome="C:\Program Files (x86)\Java\jre1.8.0_25"

# clusters' paths separated by path.separator (semicolon on Windows, colon on Unices)
#extra_clusters=

However this still does not work - the location of my java file is .. C:\Program Files (x86)\Java\jre1.8.0_25

fareeha
Posts: 2
Joined: 17 Nov 2014 10:27

Re: installation problems

Post by fareeha » 17 Nov 2014 10:33

I have did the same as you directed but, its still not working.
Can you please help me?
windows 8.1
C:\Program Files\Java\jdk1.7.0_71

elassoj1
Posts: 1
Joined: 06 Dec 2014 10:43

Re: installation problems

Post by elassoj1 » 06 Dec 2014 10:54

Thank you, it works!!!

jbrener
Posts: 3
Joined: 02 Nov 2013 05:21
Location: United States

Re: installation problems

Post by jbrener » 11 Jan 2015 23:09

Yeah - worked for me too - Thanks a lot!!

Post Reply