Gephi Warning gexf version 1.2 is deprecated

Get help with your data
Post Reply
CodeIt
Posts: 8
Joined: 02 Oct 2017 07:06

Gephi Warning gexf version 1.2 is deprecated

Post by CodeIt » 02 Oct 2017 11:40

Hello,
when I'm trying to write graphs in gexf format and open it with Gephi then I get the warning that the
gexf version 1.2 is deprecated.
When trying to solve the problem with

nx.write_gexf(graph, "gephifile.gexf", version="1.3draft")

I get the error message:
networkx.exception.NetworkXError: Unknown GEXF version 1.3draft

I use Python 3.4 and installed networkx with the following command: pip install networkx.

How can I avoid this warning? How can I upgrade to gexf version 1.3?

Thankx in advance.

User avatar
eduramiba
Gephi Code Manager
Posts: 920
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: Gephi Warning gexf version 1.2 is deprecated

Post by eduramiba » 02 Oct 2017 12:06

It seems networkx does not recognize 1.3.
You can continue using 1.2 without problems anyway, the import should work fine in Gephi.

CodeIt
Posts: 8
Joined: 02 Oct 2017 07:06

Re: Gephi Warning gexf version 1.2 is deprecated

Post by CodeIt » 02 Oct 2017 12:28

Thank you

Post Reply