Problem at import from GraphML

Get help with your data
Post Reply
dk766258
Posts: 2
Joined: 17 May 2017 09:05

Problem at import from GraphML

Post by dk766258 » 17 May 2017 09:18

I save a graph (generated with NetworkX) and save it in graphml and try to import it in Gephi
The nodes have the following attributes:
- id
- label (similar value with the id)
- x, y, z
- r, g, b

After importing in Gephi I see that some attributes are wrong: the label field contains the value from one of the rgb components, the r,g,b values are wrong and so the color of the node is wrong etc.

The problem (seems to be) that the attributes do not appear in order in the file. Could anyone advice how to avoid this problem ?
Attachments
test.graphml
(2.16 KiB) Downloaded 36 times

User avatar
eduramiba
Gephi Code Manager
Posts: 923
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: Problem at import from GraphML

Post by eduramiba » 18 May 2017 19:42

Bug confirmed, can you please report an issue at https://github.com/gephi/gephi ?

dk766258
Posts: 2
Joined: 17 May 2017 09:05

Re: Problem at import from GraphML

Post by dk766258 » 19 May 2017 12:29


GordonTer
Posts: 1
Joined: 15 Aug 2017 10:54

Re: Problem at import from GraphML

Post by GordonTer » 21 Aug 2017 10:17

Was this bug fixed?

User avatar
eduramiba
Gephi Code Manager
Posts: 923
Joined: 22 Mar 2010 15:30
Location: Madrid, Spain

Re: Problem at import from GraphML

Post by eduramiba » 21 Aug 2017 10:39

Yes, please test with the latest 0.9.2-SNAPSHOT version at https://github.com/gephi/gephi/#nightly-builds

Post Reply