Page 1 of 2

Issue with the start date for nodes

Posted: 30 Nov 2017 17:14
by sunny12
Hello ,
I'm trying to create a dynamic graph according the start day of presence of each nodes, in my CSV file I could see the nodes that have the different start day but when I import this file to the Gephi , in the start column I could see one of the start dates , Is there any solution ?
my end dates are diffrent from the start days for example
name start end
n1 2017-01-01 2017-05-30
n2 2017-05-01 2017-08-30

but after importing the data in gephi I have all the start days 2017-01-01 !!!!!

I try to do the same thing in https://seinecle.github.io/gephi-tutori ... namic.html

I have another question about the time line , Is ther a way to choose the time line for nodes or edges ?
suppose that we have intervals for edges and interval for nodes , is there a capacity too choose wich interval appears in timeline? I think the edges timeline is default ?

Thanks,

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 10:03
by eduramiba
Did you choose both start and end dates for merge and the correct date format? (yyyy-MM-dd)

Also check https://github.com/gephi/gephi/wiki/Import-Dynamic-Data

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 17:32
by sunny12
I did all the possibilities but it didn't work like the example that you provide in tutorial , Please help me to learn how to calculate time interval , I really need this feature .If you have the tutorial for that please let me know , I couldn't find a complete version .
my questions :
1- How could I do merge in 3 columns ?
2- How we could have the same time line for edges and nodes ? actually i did the same steps in https://seinecle.github.io/gephi-tutori ... namic.html but I have not the same results.
3- I want to know how nodes appearing on screen at their start date, and leaving the screen at their end date?

Could I have the data for the example of tutorila to compare ?!


Thanks millions

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 18:01
by eduramiba
Hi,
Please attach your files and I will do it and describe steps

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 19:20
by sunny12
this is nodes and the edges files !
Thanks

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 22:10
by eduramiba
You should not have a blank header column at the start of nodes file, or it will be auto-interpreted as a matrix input (you can still choose nodes table during import wizard but that produces bad column data).

Same about edges. Also, they contain interval data for parsing but the formatting is incorrect, so you still need to merge start and end columns and not use the interval column.

I fixed your files and created the final network (attached).

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 22:27
by eduramiba
Mmm reviewing the file, it seems there is a bug with the parsing of dates and the applied timezone (it should use the timezone configured in the graph configuration, but must be using my own computer timezone and creating wrong dates). Let me check it and find a workaround (probably set your computer time zone to UTC).

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 22:34
by eduramiba
I was able to produce a correct final file by setting the graph timezone to my computer timezone.
I attach it, and will create an issue in github about this (date parsing and exporting to gexf in 'Date' mode should produce consistent results).

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 22:36
by eduramiba

Re: Issue with the start date for nodes

Posted: 01 Dec 2017 23:09
by sunny12
I will check a gain and will let you know the result , I will attach my result .
I want to check why the nodes that not exist at july appears still in graph .

Thanks millions For your great help !